<!doctype html><html lang="en-US" prefix="og: https://ogp.me/ns#"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><link  rel="profile" href="https://gmpg.org/xfn/11" /><title>Here’s to Boogie Being the Start of a Prolific Filmmaking Career for Eddie Huang &bull; High Times</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://hightimes.com/wp-content/cache/min/1/6268a7e3b9e0805bfdc5d6c438ff95c7.css" data-rocket-async="style" as="style" onload="this.onload=null;this.rel='stylesheet'" media="all" data-minify="1" /><meta name="description" content="The chef, TV personality, and self-described &quot;Human Panda&quot; can now add ‘movie director’ to his already impressive resume. Let’s hope it will keep expanding."/><meta name="robots" content="index, follow, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/><link rel="canonical" href="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" /><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Here’s to Boogie Being the Start of a Prolific Filmmaking Career for Eddie Huang &bull; High Times"><meta property="og:description" content="The chef, TV personality, and self-described &quot;Human Panda&quot; can now add ‘movie director’ to his already impressive resume. Let’s hope it will keep expanding."><meta property="og:url" content="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/"><meta property="og:site_name" content="High Times"><meta property="article:publisher" content="https://www.facebook.com/HighTimesMag/"><meta property="article:tag" content="basketball"><meta property="article:tag" content="movies"><meta property="article:tag" content="Review"><meta property="article:section" content="Movies"><meta property="og:updated_time" content="2021-03-23T16:07:31-07:00"><meta property="fb:app_id" content="126230221420891"><meta property="og:image" content="https://hightimes.com/wp-content/uploads/2021/03/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang-featured-1440x960.jpg"><meta property="og:image:secure_url" content="https://hightimes.com/wp-content/uploads/2021/03/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang-featured-1440x960.jpg"><meta property="og:image:width" content="1200"><meta property="og:image:height" content="800"><meta property="og:image:alt" content="Here’s to Boogie Being The Start of a Prolific Filmmaking Career for Eddie Huang"><meta property="og:image:type" content="image/jpeg"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:title" content="Here’s to Boogie Being the Start of a Prolific Filmmaking Career for Eddie Huang &bull; High Times"><meta name="twitter:description" content="The chef, TV personality, and self-described &quot;Human Panda&quot; can now add ‘movie director’ to his already impressive resume. Let’s hope it will keep expanding."><meta name="twitter:site" content="@HIGH_TIMES_Mag"><meta name="twitter:creator" content="@HIGH_TIMES_Mag"><meta name="twitter:image" content="https://hightimes.com/wp-content/uploads/2021/03/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang-featured-1440x960.jpg"> <script  type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":"Place","@id":"https://hightimes.com/#place"},{"@type":"Organization","@id":"https://hightimes.com/#organization","name":"High Times","url":"https://hightimes.com","logo":{"@type":"ImageObject","url":"https://hightimes.com/wp-content/uploads/2016/06/HT-logo.png"},"location":{"@id":"https://hightimes.com/#place"}},{"@type":"WebSite","@id":"https://hightimes.com/#website","url":"https://hightimes.com","name":"High Times","publisher":{"@id":"https://hightimes.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#primaryImage","url":"https://hightimes.com/wp-content/uploads/2021/03/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang-featured.jpg","width":"2500","height":"1667"},{"@type":"BreadcrumbList","@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#breadcrumb","itemListElement":[{"@type":"ListItem","position":"1","item":{"@id":"https://hightimes.com","name":"Home"}},{"@type":"ListItem","position":"2","item":{"@id":"https://hightimes.com/culture/movies/","name":"Movies"}},{"@type":"ListItem","position":"3","item":{"@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/","name":"Here\u2019s to  Boogie  Being the Start of a Prolific Filmmaking Career for Eddie Huang"}}]},{"@type":"WebPage","@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#webpage","url":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/","name":"Here\u2019s to Boogie Being the Start of a Prolific Filmmaking Career for Eddie Huang &bull; High Times","datePublished":"2021-03-23T16:07:27-07:00","dateModified":"2021-03-23T16:07:31-07:00","isPartOf":{"@id":"https://hightimes.com/#website"},"primaryImageOfPage":{"@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#primaryImage"},"inLanguage":"en-US","breadcrumb":{"@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#breadcrumb"}},{"@type":"NewsArticle","headline":"Here\u2019s to Boogie Being the Start of a Prolific Filmmaking Career for Eddie Huang &bull; High Times","datePublished":"2021-03-23T16:07:27-07:00","dateModified":"2021-03-23T16:07:31-07:00","author":{"@type":"Person","name":"Tim Brinkhof"},"publisher":{"@id":"https://hightimes.com/#organization"},"description":"The chef, TV personality, and self-described &quot;Human Panda&quot; can now add \u2018movie director\u2019 to his already impressive resume. Let\u2019s hope it will keep expanding.","@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#richSnippet","isPartOf":{"@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#webpage"},"image":{"@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#primaryImage"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#webpage"}}]}</script> <link rel="amphtml" href="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/amp/" /><meta name="generator" content="AMP for WP 1.0.76.8"/><link rel='dns-prefetch' href='//static.klaviyo.com' /><link rel='dns-prefetch' href='//www.google.com' /><link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /><link rel="alternate" type="application/rss+xml" title="High Times &raquo; Feed" href="https://hightimes.com/feed/" /><link rel="alternate" type="application/rss+xml" title="High Times &raquo; Comments Feed" href="https://hightimes.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="High Times &raquo; Here’s to Boogie Being the Start of a Prolific Filmmaking Career for Eddie Huang Comments Feed" href="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/feed/" /><link rel="preload" href="https://3ncb884ou5e49t9eb3fpeur1-wpengine.netdna-ssl.com/wp-content/plugins/canvas/assets/fonts/canvas-icons.woff" as="font" type="font/woff" crossorigin><link rel="preload" href="https://3ncb884ou5e49t9eb3fpeur1-wpengine.netdna-ssl.com/wp-content/plugins/powerkit/assets/fonts/powerkit-icons.woff" as="font" type="font/woff" crossorigin> <script type='text/javascript' id='wpo_min-header-0-js-extra'>/* <![CDATA[*/var accordions_ajax={"accordions_ajaxurl":"https:\/\/hightimes.com\/wp-admin\/admin-ajax.php"};var tpbr_settings={"initial_state":"open","user_who":"notloggedin","fixed":"notfixed","guests_or_users":"all","yn_close":"close","fontsize":"15","delay":"0","border":"noborder","message":"\ud83d\udc4b High Times Delivery is open in California! Get 25% off today for High Times Tuesday!","status":"active","yn_button":"button","color":"#ec1c24","button_text":"Place an Order","button_url":"https:\/\/hightimes.com\/delivery","button_behavior":"newwindow","is_admin_bar":"","close_url":"https://cdn.shortpixel.ai/spai/q_lossy+ret_img/https://hightimes.com/wp-content/plugins/topbar-pro/inc/../images/close.png","excluded_ids":"273249, 273281, 273169","post_id":"277973","user_role":"guest","detect_sticky":"1","role_administrator":"1","role_editor":"1","role_author":"1","role_contributor":"1","role_subscriber":"1","role_customer":"1","role_shop_manager":"1"}/*]]> */</script>  <link rel="https://api.w.org/" href="https://hightimes.com/wp-json/" /><link rel="alternate" type="application/json" href="https://hightimes.com/wp-json/wp/v2/posts/277973" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://hightimes.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://hightimes.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://hightimes.com/?p=277973' /><link rel="alternate" type="application/json+oembed" href="https://hightimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhightimes.com%2Fculture%2Fmovies%2Fheres-boogie-being-start-prolific-filmmaking-career-eddie-huang%2F" /><link rel="alternate" type="text/xml+oembed" href="https://hightimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhightimes.com%2Fculture%2Fmovies%2Fheres-boogie-being-start-prolific-filmmaking-career-eddie-huang%2F&#038;format=xml" /><link rel="preload" href="https://3ncb884ou5e49t9eb3fpeur1-wpengine.netdna-ssl.com/wp-content/plugins/absolute-reviews/fonts/absolute-reviews-icons.woff" as="font" type="font/woff" crossorigin><style type="text/css" media="all" id="canvas-blocks-dynamic-styles"></style> <style id='csco-theme-typography'>:root{--cs-font-base-family:Inter;--cs-font-base-size:1.2rem;--cs-font-base-weight:400;--cs-font-base-style:normal;--cs-font-base-letter-spacing:normal;--cs-font-base-line-height:1.7;--cs-font-primary-family:Inter;--cs-font-primary-size:.875rem;--cs-font-primary-weight:600;--cs-font-primary-style:normal;--cs-font-primary-letter-spacing:-.025em;--cs-font-primary-text-transform:none;--cs-font-secondary-family:Inter;--cs-font-secondary-size:.75rem;--cs-font-secondary-weight:400;--cs-font-secondary-style:normal;--cs-font-secondary-letter-spacing:normal;--cs-font-secondary-text-transform:none;--cs-font-category-family:-apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue";--cs-font-category-size:.625rem;--cs-font-category-weight:700;--cs-font-category-style:normal;--cs-font-category-letter-spacing:-.025em;--cs-font-category-text-transform:uppercase;--cs-font-post-meta-family:-apple-system,BlinkMacSystemFont,"Segoe UI",Roboto,Oxygen-Sans,Ubuntu,Cantarell,"Helvetica Neue";--cs-font-post-meta-size:.6255rem;--cs-font-post-meta-weight:400;--cs-font-post-meta-style:normal;--cs-font-post-meta-letter-spacing:normal;--cs-font-post-meta-text-transform:uppercase;--cs-font-input-family:Inter;--cs-font-input-size:.75rem;--cs-font-input-line-height:1.625rem;--cs-font-input-weight:400;--cs-font-input-style:normal;--cs-font-input-letter-spacing:normal;--cs-font-input-text-transform:none;--cs-font-post-subtitle-family:inherit;--cs-font-post-subtitle-size:1.25rem;--cs-font-post-subtitle-letter-spacing:normal;--cs-font-post-content-family:Inter;--cs-font-post-content-size:1rem;--cs-font-post-content-letter-spacing:normal;--cs-font-entry-summary-family:Inter;--cs-font-entry-summary-size:1rem;--cs-font-entry-summary-letter-spacing:normal;--cs-font-entry-excerpt-family:Inter;--cs-font-entry-excerpt-size:.875rem;--cs-font-entry-excerpt-letter-spacing:normal;--cs-font-main-logo-family:Inter;--cs-font-main-logo-size:1.5rem;--cs-font-main-logo-weight:700;--cs-font-main-logo-style:normal;--cs-font-main-logo-letter-spacing:-.075em;--cs-font-main-logo-text-transform:none;--cs-font-large-logo-family:Inter;--cs-font-large-logo-size:1.75rem;--cs-font-large-logo-weight:700;--cs-font-large-logo-style:normal;--cs-font-large-logo-letter-spacing:-.075em;--cs-font-large-logo-text-transform:none;--cs-font-footer-logo-family:Inter;--cs-font-footer-logo-size:1.5rem;--cs-font-footer-logo-weight:700;--cs-font-footer-logo-style:normal;--cs-font-footer-logo-letter-spacing:-.075em;--cs-font-footer-logo-text-transform:none;--cs-font-headings-family:Montserrat;--cs-font-headings-weight:800;--cs-font-headings-style:normal;--cs-font-headings-line-height:1.25;--cs-font-headings-letter-spacing:-.0125em;--cs-font-headings-text-transform:none;--cs-font-styled-heading-line-height:1.4em;--cs-font-decorated-heading-family:Montserrat;--cs-font-decorated-heading-font-size:1.25rem;--cs-font-decorated-heading-weight:700;--cs-font-decorated-heading-style:normal;--cs-font-decorated-heading-line-height:1;--cs-font-decorated-heading-letter-spacing:0em;--cs-font-decorated-heading-text-transform:uppercase;--cs-font-menu-family:Inter;--cs-font-menu-size:.875rem;--cs-font-menu-weight:700;--cs-font-menu-style:normal;--cs-font-menu-letter-spacing:-.025em;--cs-font-menu-text-transform:none;--cs-font-submenu-family:Inter;--cs-font-submenu-size:.75rem;--cs-font-submenu-weight:400;--cs-font-submenu-style:normal;--cs-font-submenu-letter-spacing:0;--cs-font-submenu-text-transform:none;--cs-font-section-headings-family:Inter;--cs-font-section-headings-size:1.25rem;--cs-font-section-headings-weight:800;--cs-font-section-headings-style:normal;--cs-font-section-headings-letter-spacing:-.025em;--cs-font-section-headings-text-transform:none}.cs-header__widgets-column{--cs-font-section-headings-family:Inter;--cs-font-section-headings-size:1.125rem;--cs-font-section-headings-weight:800;--cs-font-section-headings-style:normal;--cs-font-section-headings-letter-spacing:-.025em;--cs-font-section-headings-text-transform:none}</style><link rel="icon" href="https://cdn.shortpixel.ai/spai/q_lossy+ret_img/https://hightimes.com/wp-content/uploads/2017/11/cropped-FAVICON-1-1-32x32.png" data-spai-egr="1" sizes="32x32" /><link rel="icon" href="https://cdn.shortpixel.ai/spai/q_lossy+ret_img/https://hightimes.com/wp-content/uploads/2017/11/cropped-FAVICON-1-1-192x192.png" data-spai-egr="1" sizes="192x192" /><link rel="apple-touch-icon" href="https://cdn.shortpixel.ai/spai/q_lossy+ret_img/https://hightimes.com/wp-content/uploads/2017/11/cropped-FAVICON-1-1-180x180.png" data-spai-egr="1" /><meta name="msapplication-TileImage" content="https://hightimes.com/wp-content/uploads/2017/11/cropped-FAVICON-1-1-270x270.png" /><style type="text/css" id="wp-custom-css">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</style><style id="kirki-inline-styles">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</style><style>.ai-viewports{--ai:1}.ai-viewport-3{display:none!important}.ai-viewport-2{display:none!important}.ai-viewport-1{display:inherit!important}.ai-viewport-0{display:none!important}@media (min-width:768px) and (max-width:979px){.ai-viewport-1{display:none!important}.ai-viewport-2{display:inherit!important}}@media (max-width:767px){.ai-viewport-1{display:none!important}.ai-viewport-3{display:inherit!important}}</style> <script data-rocketlazyloadscript='data:text/javascript;base64,KGZ1bmN0aW9uKHcsZCxzLGwsaSl7d1tsXT13W2xdfHxbXTt3W2xdLnB1c2goeydndG0uc3RhcnQnOm5ldyBEYXRlKCkuZ2V0VGltZSgpLGV2ZW50OidndG0uanMnfSk7dmFyIGY9ZC5nZXRFbGVtZW50c0J5VGFnTmFtZShzKVswXSxqPWQuY3JlYXRlRWxlbWVudChzKSxkbD1sIT0nZGF0YUxheWVyJz8nJmw9JytsOicnO2ouYXN5bmM9ITA7ai5zcmM9J2h0dHBzOi8vd3d3Lmdvb2dsZXRhZ21hbmFnZXIuY29tL2d0bS5qcz9pZD0nK2krZGw7Zi5wYXJlbnROb2RlLmluc2VydEJlZm9yZShqLGYpfSkod2luZG93LGRvY3VtZW50LCdzY3JpcHQnLCdkYXRhTGF5ZXInLCdHVE0tVzNLUU01TScp' ></script>   <script data-rocketlazyloadscript='https://www.googletagmanager.com/gtag/js?id=UA-78313066-1' async ></script> <script data-rocketlazyloadscript='data:text/javascript;base64,d2luZG93LmRhdGFMYXllcj13aW5kb3cuZGF0YUxheWVyfHxbXTtmdW5jdGlvbiBndGFnKCl7ZGF0YUxheWVyLnB1c2goYXJndW1lbnRzKX0KZ3RhZygnanMnLG5ldyBEYXRlKCkpO2d0YWcoJ2NvbmZpZycsJ1VBLTc4MzEzMDY2LTEnKQ==' ></script>     <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script><link href="https://cdn.shortpixel.ai" rel="preconnect" crossorigin></head><body class="post-template-default single single-post postid-277973 single-format-standard wp-embed-responsive cs-page-layout-right cs-navbar-sticky-enabled cs-sticky-sidebar-enabled cs-stick-to-bottom" data-scheme='default' site-data-scheme='default'><div class="cs-site-overlay"></div><div class="cs-offcanvas"><div class="cs-offcanvas__header" data-scheme="dark"><nav class="cs-offcanvas__nav"><div class="cs-logo "> <a class="cs-header__logo cs-logo-once " href="https://hightimes.com/"> <img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAzMjAgODIiIHdpZHRoPSIzMjAiIGhlaWdodD0iODIiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkZoaWdodGltZXMuY29tJTJGd3AtY29udGVudCUyRnVwbG9hZHMlMkYyMDE2JTJGMDYlMkZIVC1sb2dvLnBuZyIgZGF0YS13PSIzMjAiIGRhdGEtaD0iODIiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" alt="High Times" > </a></div> <span class="cs-offcanvas__toggle" role="button"><i class="cs-icon cs-icon-x"></i></span></nav></div><aside class="cs-offcanvas__sidebar"><div class="cs-offcanvas__inner cs-offcanvas__area cs-widget-area"><div class="widget widget_nav_menu cs-d-lg-none"><div class="menu-off-canvas-2-container"><ul id="menu-off-canvas-2" class="menu"><li id="menu-item-274735" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274735"><a href="https://shop.hightimes.com">Shop</a></li><li id="menu-item-273895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-273895"><a href="https://archive.hightimes.com">Digital Archive</a></li><li id="menu-item-154828" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154828"><a target="_blank" rel="noopener" href="http://hightimes.com/magazine-subscription">Magazine Subscription</a></li><li id="menu-item-154827" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154827"><a target="_blank" rel="noopener" href="https://cannabiscup.com/">Cannabis Cup</a></li><li id="menu-item-208334" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208334"><a href="http://tv.hightimes.com">HIGHTIMES TV</a></li><li id="menu-item-265105" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265105"><a href="https://hightimes.com/espanol/">Español</a></li></ul></div></div><div class="widget powerkit_widget_featured_categories-2 powerkit_widget_featured_categories"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Featured Categories</span></span></h5><div class="widget-body"><div class="pk-featured-categories pk-featured-categories-vertical-list"><div class="pk-featured-item"><div class="pk-featured-image"> <img width="1200" height="728" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxNTY2IDk1MCIgd2lkdGg9IjE1NjYiIGhlaWdodD0iOTUwIiBkYXRhLXU9Imh0dHBzJTNBJTJGJTJGaGlnaHRpbWVzLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMCUyRjA3JTJGSW1hZ2UtMS5qcGciIGRhdGEtdz0iMTU2NiIgZGF0YS1oPSI5NTAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-large size-large" alt="High Times Greats: Paul Schrader"  sizes="(max-width: 1200px) 100vw, 1200px" /></div><div class="pk-featured-content"><div class="pk-featured-inner"><div class="pk-featured-name"> News</div></div></div> <a class="pk-featured-link" href="https://hightimes.com/news/"> <span>View Posts</span> </a></div><div class="pk-featured-item"><div class="pk-featured-image"> <img width="1000" height="714" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxMDAwIDcxNCIgd2lkdGg9IjEwMDAiIGhlaWdodD0iNzE0IiBkYXRhLXU9Imh0dHBzJTNBJTJGJTJGaGlnaHRpbWVzLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAxOCUyRjEyJTJGMC0zLmpwZyIgZGF0YS13PSIxMDAwIiBkYXRhLWg9IjcxNCIgZGF0YS1iaXA9IiI+PC9zdmc+" data-spai="1" class="attachment-large size-large" alt="gift guide"  sizes="(max-width: 1000px) 100vw, 1000px" /></div><div class="pk-featured-content"><div class="pk-featured-inner"><div class="pk-featured-name"> Guides</div></div></div> <a class="pk-featured-link" href="https://hightimes.com/guides/"> <span>View Posts</span> </a></div><div class="pk-featured-item"><div class="pk-featured-image"> <img width="1000" height="600" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxMDAwIDYwMCIgd2lkdGg9IjEwMDAiIGhlaWdodD0iNjAwIiBkYXRhLXU9Imh0dHBzJTNBJTJGJTJGaGlnaHRpbWVzLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAxOSUyRjEwJTJGSGF3YWlpLUJpZy1Hcm93bi5qcGciIGRhdGEtdz0iMTAwMCIgZGF0YS1oPSI2MDAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-large size-large" alt="Hawaii&#039;s Big Island Grown"  sizes="(max-width: 1000px) 100vw, 1000px" /></div><div class="pk-featured-content"><div class="pk-featured-inner"><div class="pk-featured-name"> Grow</div></div></div> <a class="pk-featured-link" href="https://hightimes.com/grow/"> <span>View Posts</span> </a></div><div class="pk-featured-item"><div class="pk-featured-image"> <img width="1000" height="600" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxMDAwIDYwMCIgd2lkdGg9IjEwMDAiIGhlaWdodD0iNjAwIiBkYXRhLXU9Imh0dHBzJTNBJTJGJTJGaGlnaHRpbWVzLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAxOCUyRjA2JTJGdWx0aW1hdGUtZ3VpZGUtNDIwLWZyaWVuZGx5LXN1bW1lci1ldmVudHMtbG9zLWFuZ2VsZXMtaGVyby5qcGciIGRhdGEtdz0iMTAwMCIgZGF0YS1oPSI2MDAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-large size-large" alt="The Ultimate Guide to 420-Friendly Summer Events in Los Angeles"  sizes="(max-width: 1000px) 100vw, 1000px" /></div><div class="pk-featured-content"><div class="pk-featured-inner"><div class="pk-featured-name"> Events</div></div></div> <a class="pk-featured-link" href="https://hightimes.com/events/"> <span>View Posts</span> </a></div><div class="pk-featured-item"><div class="pk-featured-image"> <img width="1200" height="800" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyNTYwIDE3MDciIHdpZHRoPSIyNTYwIiBoZWlnaHQ9IjE3MDciIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkYzbmNiODg0b3U1ZTQ5dDllYjNmcGV1cjEtd3BlbmdpbmUubmV0ZG5hLXNzbC5jb20lMkZ3cC1jb250ZW50JTJGdXBsb2FkcyUyRjIwMjAlMkYwNyUyRmpvbnMtc3RvbmUtY29sZC1xdWFyYW50aW5lLWNvcHMtd2Vlay0yLWZlYXR1cmVkLXNjYWxlZC5qcGciIGRhdGEtdz0iMjU2MCIgZGF0YS1oPSIxNzA3IiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" class="attachment-large size-large" alt="Jon’s Stone-Cold Quarantine Cops Of The Week #2"  sizes="(max-width: 1200px) 100vw, 1200px" /></div><div class="pk-featured-content"><div class="pk-featured-inner"><div class="pk-featured-name"> Entertainment</div></div></div> <a class="pk-featured-link" href="https://hightimes.com/entertainment/"> <span>View Posts</span> </a></div><div class="pk-featured-item"><div class="pk-featured-image"> <img width="1200" height="800" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyNTYwIDE3MDciIHdpZHRoPSIyNTYwIiBoZWlnaHQ9IjE3MDciIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkYzbmNiODg0b3U1ZTQ5dDllYjNmcGV1cjEtd3BlbmdpbmUubmV0ZG5hLXNzbC5jb20lMkZ3cC1jb250ZW50JTJGdXBsb2FkcyUyRjIwMjAlMkYwNyUyRm5ldy1wdWZmLXB1ZmYtcGFzcy1jdWx0dXJlLWZlYXR1cmVkLXNjYWxlZC5qcGciIGRhdGEtdz0iMjU2MCIgZGF0YS1oPSIxNzA3IiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" class="attachment-large size-large" alt="The New Puff Puff Pass Culture"  sizes="(max-width: 1200px) 100vw, 1200px" /></div><div class="pk-featured-content"><div class="pk-featured-inner"><div class="pk-featured-name"> Culture</div></div></div> <a class="pk-featured-link" href="https://hightimes.com/culture/"> <span>View Posts</span> </a></div></div></div></div><div class="widget powerkit_social_links_widget-3 powerkit_social_links_widget"><div class="widget-body"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Social Links</span></span></h5><div class="pk-social-links-wrap pk-social-links-template-inline pk-social-links-align-default pk-social-links-scheme-dark-rounded pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled"><div class="pk-social-links-items"><div class="pk-social-links-item pk-social-links-facebook pk-social-links-no-count" data-id="facebook"> <a href="https://facebook.com/hightimesmag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-facebook"></i> </a></div><div class="pk-social-links-item pk-social-links-twitter pk-social-links-no-count" data-id="twitter"> <a href="https://twitter.com/high_times_mag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-twitter"></i> </a></div><div class="pk-social-links-item pk-social-links-instagram pk-social-links-no-count" data-id="instagram"> <a href="https://www.instagram.com/hightimesmagazine" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-instagram"></i> </a></div><div class="pk-social-links-item pk-social-links-youtube pk-social-links-no-count" data-id="youtube"> <a href="https://www.youtube.com/channel/UCFQ7vc-dWlSUZd6OqsAepMA" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-youtube"></i> </a></div></div></div></div></div></div></aside></div><div id="page" class="cs-site"><div class="cs-site-inner"><div class="cs-topbar" data-scheme="dark"><div class="cs-container"><div class="cs-header__inner cs-inner-large-height"><div class="cs-header__col cs-col-left"> <span class="cs-header__offcanvas-toggle " role="button"> <i class="cs-icon cs-icon-menu"></i> </span></div><div class="cs-header__col cs-col-center"><div class="cs-logo "> <a class="cs-header__logo cs-logo-once cs-logo-large" href="https://hightimes.com/"> <img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA2MDAgMTU1IiB3aWR0aD0iNjAwIiBoZWlnaHQ9IjE1NSIgZGF0YS11PSJodHRwcyUzQSUyRiUyRmhpZ2h0aW1lcy5jb20lMkZ3cC1jb250ZW50JTJGdXBsb2FkcyUyRjIwMjAlMkYwOCUyRjYwMHgxNTUtaHQtbG9nby5qcGciIGRhdGEtdz0iNjAwIiBkYXRhLWg9IjE1NSIgZGF0YS1iaXA9IiI+PC9zdmc+" data-spai="1" alt="High Times" > </a></div></div><div class="cs-header__col cs-col-right"><div class="cs-navbar-social-links"><div class="pk-social-links-wrap pk-social-links-template-nav pk-social-links-align-default pk-social-links-scheme-default pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled"><div class="pk-social-links-items"><div class="pk-social-links-item pk-social-links-facebook pk-social-links-no-count" data-id="facebook"> <a href="https://facebook.com/hightimesmag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-facebook"></i> </a></div><div class="pk-social-links-item pk-social-links-twitter pk-social-links-no-count" data-id="twitter"> <a href="https://twitter.com/high_times_mag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-twitter"></i> </a></div><div class="pk-social-links-item pk-social-links-instagram pk-social-links-no-count" data-id="instagram"> <a href="https://www.instagram.com/hightimesmagazine" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-instagram"></i> </a></div><div class="pk-social-links-item pk-social-links-youtube pk-social-links-no-count" data-id="youtube"> <a href="https://www.youtube.com/channel/UCFQ7vc-dWlSUZd6OqsAepMA" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-youtube"></i> </a></div></div></div></div></div></div></div></div><header class="cs-header cs-header-three" data-scheme="dark"><div class="cs-container"><div class="cs-header__inner cs-header__inner-desktop"><div class="cs-header__col cs-col-left"> <span class="cs-header__search-toggle" role="button"> <i class="cs-icon cs-icon-search"></i> </span> <span class="cs-separator"></span><div class="cs-logo cs-logo-hide"> <a class="cs-header__logo cs-logo-once " href="https://hightimes.com/"> <img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAzMjAgODIiIHdpZHRoPSIzMjAiIGhlaWdodD0iODIiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkZoaWdodGltZXMuY29tJTJGd3AtY29udGVudCUyRnVwbG9hZHMlMkYyMDE2JTJGMDYlMkZIVC1sb2dvLnBuZyIgZGF0YS13PSIzMjAiIGRhdGEtaD0iODIiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" alt="High Times" > </a></div></div><div class="cs-header__col cs-col-center"><nav class="cs-header__nav"><ul id="menu-ht-top-main-nav" class="cs-header__nav-inner"><li id="menu-item-174064" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-174064"><a href="https://hightimes.com/news/"><span>News</span></a><ul class="sub-menu" data-scheme="default"><li id="menu-item-208257" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208257"><a href="https://hightimes.com/news/legalization/">Legalization</a></li><li id="menu-item-208256" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208256"><a href="https://hightimes.com/news/politics/">Politics</a></li><li id="menu-item-277010" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-277010"><a href="#">Browse By State</a><ul class="sub-menu" data-scheme="default"><li id="menu-item-277013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277013"><a href="https://hightimes.com/news/arizona/">Arizona</a></li><li id="menu-item-277014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277014"><a href="https://hightimes.com/news/colorado/">Colorado</a></li><li id="menu-item-277015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277015"><a href="https://hightimes.com/news/michigan/">Michigan</a></li><li id="menu-item-277016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277016"><a href="https://hightimes.com/news/illinois/">Illinois</a></li><li id="menu-item-277017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277017"><a href="https://hightimes.com/news/oklahoma/">Oklahoma</a></li><li id="menu-item-277018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277018"><a href="https://hightimes.com/news/oregon/">Oregon</a></li><li id="menu-item-277019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277019"><a href="https://hightimes.com/news/washington/">Washington</a></li></ul></li></ul></li><li id="menu-item-208261" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208261 cs-mega-menu cs-mega-menu-term menu-item-has-children"><a href="https://hightimes.com/business/" data-term="28301" data-numberposts="5"><span>Business</span></a><div class="sub-menu" data-scheme="default"><div class="cs-mm__posts mega-menu-term"></div></div></li><li id="menu-item-174065" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-174065 cs-mega-menu cs-mega-menu-term menu-item-has-children"><a href="https://hightimes.com/culture/" data-term="28300" data-numberposts="5"><span>Culture</span></a><div class="sub-menu" data-scheme="default"><div class="cs-mm__posts mega-menu-term"></div></div></li><li id="menu-item-208272" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-208272 cs-mega-menu cs-mega-menu-term menu-item-has-children"><a href="https://hightimes.com/events/" data-term="167439" data-numberposts="5"><span>Events</span></a><div class="sub-menu" data-scheme="default"><div class="cs-mm__posts mega-menu-term"></div></div></li><li id="menu-item-174066" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-174066 cs-mega-menu cs-mega-menu-term menu-item-has-children"><a href="https://hightimes.com/grow/" data-term="21" data-numberposts="5"><span>Grow</span></a><div class="sub-menu" data-scheme="default"><div class="cs-mm__posts mega-menu-term"></div></div></li><li id="menu-item-276755" class="mvp-mega-dropdown menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276755 cs-mega-menu cs-mega-menu-term menu-item-has-children"><a href="https://hightimes.com/products/" data-term="28307" data-numberposts="5"><span>Products</span></a><div class="sub-menu" data-scheme="default"><div class="cs-mm__posts mega-menu-term"></div></div></li><li id="menu-item-274732" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274732"><a target="_blank" rel="noopener" href="https://shop.hightimes.com"><span>Shop</span></a></li><li id="menu-item-266862" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-266862"><a target="_blank" rel="noopener" href="https://ir.hightimes.com"><span>IR</span></a></li></ul></nav><div class="cs-header__multi-column cs-site-submenu section-heading-default-style-3"> <span class="cs-header__multi-column-toggle"><i class="cs-icon cs-icon-more-horizontal"></i> </span><div class="cs-header__multi-column-container" data-scheme="default"><div class="cs-header__multi-column-row"><div class="cs-header__multi-column-col cs-header__widgets-column cs-widget-area"><div class="widget nav_menu-10 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Sponsored</span></span></h5><div class="menu-mutli-column-1-sponsored-container"><ul id="menu-mutli-column-1-sponsored" class="menu"><li id="menu-item-277020" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277020"><a href="https://hightimes.com/sponsored/six-top-tasty-cannabis-strains/">Six Top Tasty Cannabis Strains</a></li><li id="menu-item-277021" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277021"><a href="https://hightimes.com/sponsored/cannabis-decontamination-matters/">Cannabis Decontamination Matters</a></li><li id="menu-item-277022" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277022"><a href="https://hightimes.com/sponsored/cbd-oil-uk/">CBD Oil in the UK — 5 Best CBD Oils You Can Buy in 2021</a></li></ul></div></div><div class="widget nav_menu-9 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Reviews</span></span></h5><div class="menu-mutli-column-1-reviews-container"><ul id="menu-mutli-column-1-reviews" class="menu"><li id="menu-item-277024" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277024"><a href="https://hightimes.com/products/jons-stone-cold-quarantine-cop-list-6/">Jon’s Stone-Cold Quarantine Cop List 6</a></li><li id="menu-item-277025" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277025"><a href="https://hightimes.com/products/give-yourself-gift-most-luxurious-cbd-skincare-products-market/">Give Yourself The Gift of the Most Luxurious CBD Skincare Products on the Market</a></li><li id="menu-item-277023" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277023"><a href="https://hightimes.com/product-review/review-doja-paks-rs-11/">REVIEW: Doja Pak’s RS-11</a></li></ul></div></div><div class="widget nav_menu-8 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Guides</span></span></h5><div class="menu-mutli-column-1-guides-container"><ul id="menu-mutli-column-1-guides" class="menu"><li id="menu-item-277028" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277028"><a href="https://hightimes.com/grow/grow-weed-guide-beginners/">How To Grow Weed: A Step-by-Step Guide For Beginners</a></li><li id="menu-item-277027" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277027"><a href="https://hightimes.com/guides/how-to-roll-a-joint/">How To Roll A Joint: A Step-by-Step Guide</a></li><li id="menu-item-277026" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277026"><a href="https://hightimes.com/guides/a-beginners-guide-to-cbd/">A Beginner’s Guide to CBD</a></li></ul></div></div></div><div class="cs-header__multi-column-col cs-header__widgets-column cs-widget-area"><div class="widget nav_menu-12 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Business</span></span></h5><div class="menu-multi-column-2-business-container"><ul id="menu-multi-column-2-business" class="menu"><li id="menu-item-277034" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277034"><a href="https://hightimes.com/business/red-white-bloom-high-times-collab-releases-more-products-michigan/">Red White &#038; Bloom and High Times Collab Releases More Products in Michigan</a></li><li id="menu-item-277033" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277033"><a href="https://hightimes.com/business/new-way-engage-high-times-shop-relaunch/">A New Way To Engage: The High Times Shop Relaunch</a></li><li id="menu-item-277032" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277032"><a href="https://hightimes.com/business/brand-spotlight-cannabiotix/">Brand Spotlight: Cannabiotix</a></li></ul></div></div><div class="widget nav_menu-11 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Culture</span></span></h5><div class="menu-multi-column-2-culture-container"><ul id="menu-multi-column-2-culture" class="menu"><li id="menu-item-277029" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277029"><a href="https://hightimes.com/high-times-greats/rob-thomas/">High Times Greats: Rob Thomas</a></li><li id="menu-item-277030" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277030"><a href="https://hightimes.com/women/black-history-month-spotlight-antoinette-wade-founder-gratitude-blossom/">Black History Month Spotlight: Antoinette Wade, Founder, Gratitude Blossom</a></li><li id="menu-item-277031" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-277031"><a href="https://hightimes.com/flashback-friday/snakes/">Flashback Friday: Snakes</a></li></ul></div></div><div class="widget nav_menu-6 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>High Times Network</span></span></h5><div class="menu-off-canvas-2-container"><ul id="menu-off-canvas-3" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274735"><a href="https://shop.hightimes.com">Shop</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-273895"><a href="https://archive.hightimes.com">Digital Archive</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154828"><a target="_blank" rel="noopener" href="http://hightimes.com/magazine-subscription">Magazine Subscription</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-154827"><a target="_blank" rel="noopener" href="https://cannabiscup.com/">Cannabis Cup</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208334"><a href="http://tv.hightimes.com">HIGHTIMES TV</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-265105"><a href="https://hightimes.com/espanol/">Español</a></li></ul></div></div></div><div class="cs-header__multi-column-col cs-header__widgets-column cs-widget-area"><div class="widget nav_menu-7 widget_nav_menu"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Our Company</span></span></h5><div class="menu-ht-footer-nav-container"><ul id="menu-ht-footer-nav" class="menu"><li id="menu-item-275350" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-275350"><a href="/magazine-subscription">Subscribe</a></li><li id="menu-item-271309" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271309"><a href="https://hightimes.com/advertise/">Advertise</a></li><li id="menu-item-271311" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271311"><a href="https://hightimes.com/classifieds/">Classifieds</a></li><li id="menu-item-271310" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271310"><a href="https://hightimes.com/legal/">Legal Directory</a></li><li id="menu-item-174072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174072"><a href="https://hightimes.com/about/">Our Company</a></li><li id="menu-item-275853" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275853"><a href="https://hightimes.com/terms-of-use/">Terms of Use</a></li><li id="menu-item-174074" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-174074"><a href="https://hightimes.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-275854" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275854"><a href="https://hightimes.com/california-residents-privacy-notice/">California Residents Privacy Notice</a></li><li id="menu-item-174076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174076"><a href="https://hightimes.com/submissions/">Write For Us</a></li><li id="menu-item-196428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-196428"><a href="https://ir.hightimes.com">Investor Relations</a></li></ul></div></div><div class="widget powerkit_social_links_widget-4 powerkit_social_links_widget"><div class="widget-body"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Social Links</span></span></h5><div class="pk-social-links-wrap pk-social-links-template-inline pk-social-links-align-default pk-social-links-scheme-light pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled"><div class="pk-social-links-items"><div class="pk-social-links-item pk-social-links-facebook pk-social-links-no-count" data-id="facebook"> <a href="https://facebook.com/hightimesmag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-facebook"></i> </a></div><div class="pk-social-links-item pk-social-links-twitter pk-social-links-no-count" data-id="twitter"> <a href="https://twitter.com/high_times_mag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-twitter"></i> </a></div><div class="pk-social-links-item pk-social-links-instagram pk-social-links-no-count" data-id="instagram"> <a href="https://www.instagram.com/hightimesmagazine" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-instagram"></i> </a></div><div class="pk-social-links-item pk-social-links-youtube pk-social-links-no-count" data-id="youtube"> <a href="https://www.youtube.com/channel/UCFQ7vc-dWlSUZd6OqsAepMA" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-youtube"></i> </a></div></div></div></div></div><div class="widget powerkit_opt_in_subscription_widget-3 powerkit_opt_in_subscription_widget"><div class="widget-body"><div class="pk-subscribe-form-wrap pk-subscribe-form-widget"><div class="pk-subscribe-container "><div class="pk-subscribe-data"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Free Newsletter</span></span></h5><form method="post" class="subscription"> <input type="hidden" name="list_id" value="3c14e9f298"><div class="pk-input-group"> <input type="text" name="EMAIL" class="email form-control" placeholder="Enter your email"> <button class="pk-subscribe-submit" type="submit">Subscribe</button></div> <input type="hidden" name="_wp_http_referer" value="/author/hightimes/" /></form></div></div></div></div></div></div></div></div></div></div><div class="cs-header__col cs-col-right"> <button class="ht-header-getweed" onclick="location.href='www.hightimes.com/getweed'">Get Weed</button></div></div><div class="cs-header__inner cs-header__inner-mobile"><div class="cs-header__col cs-col-left"> <span class="cs-header__offcanvas-toggle " role="button"> <i class="cs-icon cs-icon-menu"></i> </span></div><div class="cs-header__col cs-col-center"><div class="cs-logo "> <a class="cs-header__logo cs-logo-once " href="https://hightimes.com/"> <img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAzMjAgODIiIHdpZHRoPSIzMjAiIGhlaWdodD0iODIiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkZoaWdodGltZXMuY29tJTJGd3AtY29udGVudCUyRnVwbG9hZHMlMkYyMDE2JTJGMDYlMkZIVC1sb2dvLnBuZyIgZGF0YS13PSIzMjAiIGRhdGEtaD0iODIiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" alt="High Times" > </a></div></div><div class="cs-header__col cs-col-right"> <span class="cs-header__search-toggle" role="button"> <i class="cs-icon cs-icon-search"></i> </span></div></div></div><div class="cs-search" data-scheme="default"><div class="cs-container"><form role="search" method="get" class="cs-search__nav-form" action="https://hightimes.com/"><div class="cs-search__group"> <button class="cs-search__submit"> <i class="cs-icon cs-icon-search"></i> </button> <input data-swpparentel=".cs-header .cs-search-live-result" required class="cs-search__input" data-swplive="true" type="search" value="" name="s" placeholder="Enter your search topic"> <button class="cs-search__close"> <i class="cs-icon cs-icon-x"></i> </button></div></form><div class="cs-search__content"><div class="cs-search__posts"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>The Latest</span></span></h5><div class="cs-search__posts-wrapper"><article class="post-277973 post type-post status-publish format-standard has-post-thumbnail category-movies category-culture tag-basketball tag-movies tag-review cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse"><div class="cs-overlay-background cs-overlay-transparent"> <img width="110" height="110" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyMjAgMjIwIiB3aWR0aD0iMjIwIiBoZWlnaHQ9IjIyMCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGaGVyZXMtYm9vZ2llLWJlaW5nLXN0YXJ0LXByb2xpZmljLWZpbG1tYWtpbmctY2FyZWVyLWVkZGllLWh1YW5nLWZlYXR1cmVkLTIyMHgyMjAuanBnIiBkYXRhLXc9IjIyMCIgZGF0YS1oPSIyMjAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-csco-small size-csco-small wp-post-image" alt="Here’s to Boogie Being The Start of a Prolific Filmmaking Career for Eddie Huang"  sizes="(max-width: 110px) 100vw, 110px" /></div> <a href="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><h6 class="cs-entry__title"><a href="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/">Here’s to <i> Boogie </i> Being the Start of a Prolific Filmmaking Career for Eddie Huang</a></h6><div class="cs-entry__post-meta" ></div></div></div></article><article class="post-277968 post type-post status-publish format-standard has-post-thumbnail category-kansas category-news tag-kansas tag-medical-marijuana cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse"><div class="cs-overlay-background cs-overlay-transparent"> <img width="110" height="110" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyMjAgMjIwIiB3aWR0aD0iMjIwIiBoZWlnaHQ9IjIyMCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGa2Fuc2FzLWxhd21ha2Vycy1jb25zaWRlci1zdHJpY3RseS1yZWd1bGF0ZWQtbWVkaWNhbC1tYXJpanVhbmEtcHJvZ3JhbS1mZWF0dXJlZC0yMjB4MjIwLmpwZyIgZGF0YS13PSIyMjAiIGRhdGEtaD0iMjIwIiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" class="attachment-csco-small size-csco-small wp-post-image" alt="Kansas Lawmakers Consider Strictly Regulated Medical Marijuana Program"  sizes="(max-width: 110px) 100vw, 110px" /></div> <a href="https://hightimes.com/news/kansas/kansas-lawmakers-consider-strictly-regulated-medical-marijuana-program/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><h6 class="cs-entry__title"><a href="https://hightimes.com/news/kansas/kansas-lawmakers-consider-strictly-regulated-medical-marijuana-program/">Kansas Lawmakers Consider Strictly Regulated Medical Marijuana Program</a></h6><div class="cs-entry__post-meta" ></div></div></div></article><article class="post-277963 post type-post status-publish format-standard has-post-thumbnail category-illinois category-news tag-illinois tag-justice tag-race cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse"><div class="cs-overlay-background cs-overlay-transparent"> <img width="110" height="110" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyMjAgMjIwIiB3aWR0aD0iMjIwIiBoZWlnaHQ9IjIyMCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGZXZhbnN0b24taWxsaW5vaXMtZnVuZC1yZXBhcmF0aW9ucy1ibGFjay1jb21tdW5pdHktY2FubmFiaXMtdGF4LXJldmVudWUtZmVhdHVyZWQtMjIweDIyMC5qcGciIGRhdGEtdz0iMjIwIiBkYXRhLWg9IjIyMCIgZGF0YS1iaXA9IiI+PC9zdmc+" data-spai="1" class="attachment-csco-small size-csco-small wp-post-image" alt="Evanston, Illinois To Fund Reparations To Black Community With Cannabis Tax Revenue"  sizes="(max-width: 110px) 100vw, 110px" /></div> <a href="https://hightimes.com/news/illinois/evanston-illinois-fund-reparations-black-community-cannabis-tax-revenue/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><h6 class="cs-entry__title"><a href="https://hightimes.com/news/illinois/evanston-illinois-fund-reparations-black-community-cannabis-tax-revenue/">Evanston, Illinois To Fund Reparations To Black Community With Cannabis Tax Revenue</a></h6><div class="cs-entry__post-meta" ></div></div></div></article><article class="post-277959 post type-post status-publish format-standard has-post-thumbnail category-music category-culture tag-featured tag-interviews tag-musicians cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-square" data-scheme="inverse"><div class="cs-overlay-background cs-overlay-transparent"> <img width="110" height="110" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyMjAgMjIwIiB3aWR0aD0iMjIwIiBoZWlnaHQ9IjIyMCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGanVzdGluLWJvcmV0YS1wbGF5cy1wYXJ0LW11c2ljLWN5Y2xlLWxpZmUtZmVhdHVyZWQtMjIweDIyMC5qcGVnIiBkYXRhLXc9IjIyMCIgZGF0YS1oPSIyMjAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-csco-small size-csco-small wp-post-image" alt="Justin Boreta Plays His Part In The Music Cycle Of Life"  sizes="(max-width: 110px) 100vw, 110px" /></div> <a href="https://hightimes.com/culture/music/justin-boreta-plays-part-music-cycle-life/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><h6 class="cs-entry__title"><a href="https://hightimes.com/culture/music/justin-boreta-plays-part-music-cycle-life/">Justin Boreta Plays His Part In The Music Cycle Of Life</a></h6><div class="cs-entry__post-meta" ></div></div></div></article></div></div><div class="cs-search-live-result"></div></div></div></div></header><main id="main" class="cs-site-primary"><div class="cs-site-content cs-sidebar-enabled cs-sidebar-right cs-metabar-enabled section-heading-default-style-3"><div class="cs-container"><div id="content" class="cs-main-content"><div id="primary" class="cs-content-area"><div class="cs-entry__header cs-entry__header-simple cs-video-wrap"><div class="cs-entry__header-inner"><div class="cs-entry__header-info"><div class="cs-entry__category"><ul class="post-categories"><li><a href="https://hightimes.com/culture/movies/" rel="category tag">Movies</a></li><li><a href="https://hightimes.com/culture/" rel="category tag">Culture</a></li></ul></div><h1 class="cs-entry__title"><span>Here’s to <i> Boogie </i> Being the Start of a Prolific Filmmaking Career for Eddie Huang</span></h1><div class="cs-entry__subtitle"> The chef, TV personality, and self-described &#8220;Human Panda&#8221; can now add ‘movie director’ to his already impressive resume. Let’s hope it will keep expanding.</div><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://hightimes.com/author/timbrinkhof/" title="View all posts by Tim Brinkhof"><span class="cs-photo"><img src="https://secure.gravatar.com/avatar/934471b4d8a96133fd7293ef393dbb98?s=26&#038;d=https%3A%2F%2Fhightimes.com%2Fwp-content%2Fuploads%2F2016%2F08%2Fcropped-cropped-FAVICON-32x32.png&#038;r=g" width="26" height="26" alt="Avatar" class="avatar avatar-26 wp-user-avatar wp-user-avatar-26 photo avatar-default" /></span><span class="cs-by">by</span><span class="cs-author">Tim Brinkhof</span></a></div><div class="cs-meta-date">March 23, 2021</div></div></div><figure class="cs-entry__post-media post-media"> <img width="800" height="500" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxNjAwIDEwMDAiIHdpZHRoPSIxNjAwIiBoZWlnaHQ9IjEwMDAiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkYzbmNiODg0b3U1ZTQ5dDllYjNmcGV1cjEtd3BlbmdpbmUubmV0ZG5hLXNzbC5jb20lMkZ3cC1jb250ZW50JTJGdXBsb2FkcyUyRjIwMjElMkYwMyUyRmhlcmVzLWJvb2dpZS1iZWluZy1zdGFydC1wcm9saWZpYy1maWxtbWFraW5nLWNhcmVlci1lZGRpZS1odWFuZy1mZWF0dXJlZC0xNjAweDEwMDAuanBnIiBkYXRhLXc9IjE2MDAiIGRhdGEtaD0iMTAwMCIgZGF0YS1iaXA9IiI+PC9zdmc+" data-spai="1" class="attachment-csco-medium size-csco-medium wp-post-image" alt="Here’s to Boogie Being The Start of a Prolific Filmmaking Career for Eddie Huang"  sizes="(max-width: 800px) 100vw, 800px" /></figure><figcaption class="cs-entry__caption-text wp-caption-text"> Focus Features</figcaption></div></div><div class="cs-entry__wrap"><div class="cs-entry__container"><div class="cs-entry__metabar"><div class="cs-entry__metabar-inner"><div class="pk-share-buttons-wrap pk-share-buttons-layout-simple pk-share-buttons-scheme-bold-light pk-share-buttons-has-total-counts pk-share-buttons-metabar-post pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="277973" data-share-url="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" ><div class="pk-share-buttons-total pk-share-buttons-total-no-count"><div class="pk-share-buttons-title pk-font-primary">Total</div><div class="pk-share-buttons-count pk-font-heading">0</div><div class="pk-share-buttons-label pk-font-secondary">Shares</div></div><div class="pk-share-buttons-items"><div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter"> <a href="https://twitter.com/share?&text=Here%E2%80%99s%20to%20%3Ci%3E%20Boogie%20%3C%2Fi%3E%20Being%20the%20Start%20of%20a%20Prolific%20Filmmaking%20Career%20for%20Eddie%20Huang&via=high_times_mag&url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i> </a></div><div class="pk-share-buttons-item pk-share-buttons-linkedin pk-share-buttons-no-count" data-id="linkedin"> <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-linkedin"></i> </a></div><div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit"> <a href="http://www.reddit.com/submit?url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i> </a></div></div></div></div></div><div class="cs-entry__content-wrap"><div class="entry-content"><p>Despite spending my undergraduate years in an East Village apartment that was just a few blocks away from Baohaus, I didn’t get acquainted with Eddie Huang through his delicious pork buns. Like many, my introduction to the Asian American chef and TV personality came by way of his highly bingeable Viceland series, <em>Huang’s World</em>.&nbsp;</p><p>An unfiltered reflection of Huang’s colorful personality, <em>Huang’s World </em>employs documentary storytelling methods to combine lowbrow, bro-to-bro humor with impromptu, weed-fueled bouts of cultural analysis. In one episode, Huang may be <a href="https://www.youtube.com/watch?v=Ar-MuaZx1Ns" target="_blank" aria-label=" (opens in a new tab)" rel="noreferrer noopener nofollow" class="rank-math-link">too stoned to ask his nice old Jamaican host any worthwhile questions about her sugarcane plantation</a>. In another, he may be walking down a misty Moscow street saying something deeply profound like, “<a href="https://www.youtube.com/watch?v=unJngK-6zxg" target="_blank" aria-label=" (opens in a new tab)" rel="noreferrer noopener nofollow" class="rank-math-link">All of us want to know more about each other and understand where we’re from. But—in that quest—we gotta resist the temptation to allow any single voice to speak for an entire community</a>.” </p><p>As far as globetrotting documentarians go, Huang is up there with the likes of <a href="https://hightimes.com/news/anthony-bourdain-travel-host-cannabis-advocate-dead/" class="rank-math-link">Anthony Bourdain</a>. Not just in his understanding of the ambassadorial potential of foreign cuisines, but also in his capacity to bring together different walks of life and make strangers act as close as college roommates.</p><p>All of these qualities come through in Huang’s feature film debut, <em>Boogie</em>, about a fiery Chinese American young man’s attempt to make it to the <a href="https://hightimes.com/news/nba-players-be-tested-covid-19-not-marijuana/" class="rank-math-link">NBA</a>. Along the way, Alfred “Boogie” Chin is supported by his irresponsible, daydreaming father and tactfully discouraged by his responsible, risk averse mother. Where <a href="https://hightimes.com/health/sports-pot-role-cannabis-athletic-recovery/" class="rank-math-link">sports</a> stories are concerned, <em>Boogie </em>is and isn’t a traditional underdog narrative. Alfred has plenty of natural talent; the real enemy isn’t his opponent—an imposing Black basketball player named Monk—but his doubts about whether he can escape the stereotype-stranglehold by proving there’s more to him than “beef and broccoli.”</p><div class='code-block code-block-11' style='margin: 8px auto; text-align: center; display: block; clear: both;'>   <div id='div-gpt-ad-1583394553387-0'>  </div></div><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="cs-embed cs-embed-responsive"><iframe loading="lazy" title="BOOGIE - Official Trailer - In Theaters March 5" width="1200" height="675" src="about:blank" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.youtube.com/embed/xEpSdb_f1pE?feature=oembed"></iframe><noscript><iframe title="BOOGIE - Official Trailer - In Theaters March 5" width="1200" height="675" src="https://www.youtube.com/embed/xEpSdb_f1pE?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></noscript></div></div></figure><p>Alfred is played by Taylor Takahashi, Huang’s longtime assistant on previous projects whom he apparently met during some or other recreational b-ball game (the sport is but one of Huang’s many passions that plays center stage in this film, alongside fashion and the interplay between cultures). Though a first-time actor, Takahashi portrays the title character with confidence and authenticity.&nbsp;</p><p>Equally compelling is his co-star, the Brooklyn drill rapper Pop Smoke, who was critically injured during a home invasion and passed away at age 20, shortly after filming of <em>Boogie </em>wrapped up. <a href="https://www.xxlmag.com/pop-smoke-rapper-interview/" target="_blank" aria-label=" (opens in a new tab)" rel="noreferrer noopener nofollow" class="rank-math-link">Music magazine <em>XXL </em>has described the rapper as</a> “blessed with a rough, no-nonsense growl,” adding that “like the best villains, he’s not motivated by pure malice. Behind each threat, there’s a cocky, mischievous grin.” Those who have seen Huang’s movie will know that Pop Smoke imbued Monk with precisely that kind of energy, giving depth and weight to what might have otherwise been a predictably straightforward on-court, off-court rivalry. </p><p>Being somebody’s first, <em>Boogie </em>is not without its hiccups. Since the film’s release, various critics have called its storyline “tedious” and described the ideas underneath as immature. Whether Huang did his Asian American audience justice is not my place to say, so I won’t. While plot points like Boogie discovering his girlfriend Eleanor used to date Monk moments before his big match strike me as cringy and a wee bit cliché, I am also painfully aware of the fact that real-life teenage drama often is just that. If there’s a reviewer out there who can look me in the eye and tell me their teenage years didn’t, in some ways, feel like a rough first draft, I’ll hear their beef with <em>Boogie</em>.</p><p>This film is no Shakespearean play (though, like Huang himself, its script can certainly be poetic at times), but then again: it doesn’t need to be. What matters is that <em>Boogie </em>is a story that comes straight from the heart of its creator, a person who does not change to procure the meaningless favor of the filmmaking establishment or to rake in that extra bit of cash from the movie-going public. </p><p>This helps explain why Huang cut ties with ABC when the corporation turned his heartfelt autobiography <em>Fresh off the Boat </em>into an impersonal, mass-marketable sitcom that could attract the audiences of <em>Big Bang Theory </em>and <em>Modern Family</em>. Compared to that show, <em>Boogie </em>undoubtedly feels like the sort of movie Huang always wanted to make. That’s why I enjoyed watching it, and why I hope he will be able to make more in the future.</p></div><div class="cs-entry__after-share-buttons"><div class="pk-share-buttons-wrap pk-share-buttons-layout-equal pk-share-buttons-scheme-bold-bg pk-share-buttons-has-total-counts pk-share-buttons-after-post pk-share-buttons-mode-php pk-share-buttons-mode-rest" data-post-id="277973" data-share-url="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" ><div class="pk-share-buttons-total pk-share-buttons-total-no-count"><div class="pk-share-buttons-title pk-font-primary">Total</div><div class="pk-share-buttons-count pk-font-heading">0</div><div class="pk-share-buttons-label pk-font-secondary">Shares</div></div><div class="pk-share-buttons-items"><div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter"> <a href="https://twitter.com/share?&text=Here%E2%80%99s%20to%20%3Ci%3E%20Boogie%20%3C%2Fi%3E%20Being%20the%20Start%20of%20a%20Prolific%20Filmmaking%20Career%20for%20Eddie%20Huang&via=high_times_mag&url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i> <span class="pk-share-buttons-label pk-font-primary">Tweet</span> </a></div><div class="pk-share-buttons-item pk-share-buttons-linkedin pk-share-buttons-no-count" data-id="linkedin"> <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-linkedin"></i> <span class="pk-share-buttons-label pk-font-primary">Share</span> </a></div><div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit"> <a href="http://www.reddit.com/submit?url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i> <span class="pk-share-buttons-label pk-font-primary">Share</span> </a></div></div></div></div><div class="cs-entry__author"><div class="cs-entry__author-inner"> <a href="https://hightimes.com/author/timbrinkhof/" class="cs-entry__author-photo"> <img src="https://secure.gravatar.com/avatar/934471b4d8a96133fd7293ef393dbb98?s=100&#038;d=https%3A%2F%2Fhightimes.com%2Fwp-content%2Fuploads%2F2016%2F08%2Fcropped-cropped-FAVICON-125x125.png&#038;r=g" width="100" height="100" alt="Avatar" class="avatar avatar-100 wp-user-avatar wp-user-avatar-100 photo avatar-default" /> </a><div class="cs-entry__author-info"> <span class="cs-entry__author-position">Author</span><div class="cs-entry__author-name-wrapper"> <a href="https://hightimes.com/author/timbrinkhof/" class="cs-entry__author-name"> Tim Brinkhof </a><div class="cs-entry__author-social"></div></div></div></div></div><div class="cs-entry__comments cs-entry__comments-collapse" id="comments-hidden"><div id="respond" class="comment-respond"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/#respond" style="display:none;">Cancel reply</a></small></span></span></h5><form action="https://hightimes.com/wp-comments-post.php?wpe-comment-post=transhighcorp" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='277973' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="24bba46e72" /></p><input type="hidden" id="ak_js" name="ak_js" value="207"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form></div></div><div class="cs-entry__comments-show" id="comments"> <button>View Comments (0)</button></div><div class="cs-entry__subscribe"><div class="cs-site-subscribe__item"><div class="cs-site-subscribe__form"><div class="cs-site-subscribe__info"><h4 class="cs-site-subscribe__title">Sign Up for Our Newsletters</h4> <span class="cs-site-subscribe__info-text">Get notified of our the latest cannabis news, exclusive brand deals, events updates and more!</span></div><div class="pk-subscribe-form-wrap pk-subscribe-form-block"><div class="pk-subscribe-container "><div class="pk-subscribe-data"><form method="post" class="subscription"> <input type="hidden" name="list_id" value="3c14e9f298"><div class="pk-input-group"> <input type="text" name="EMAIL" class="email form-control" placeholder="Enter your email"> <button class="pk-subscribe-submit" type="submit">Subscribe</button></div> <input type="hidden" name="_wp_http_referer" value="/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" /></form></div></div></div></div></div></div><div class="cs-entry__prev-next cs-entry__prev-next-type-1"><div class="cs-entry__prev-next-item cs-entry__prev"> <a class="cs-entry__prev-next-link" href="https://hightimes.com/news/kansas/kansas-lawmakers-consider-strictly-regulated-medical-marijuana-program/"></a><div class="cs-entry__prev-next-label"> <span class="cs-entry__prev-next-arrow"> <i class="cs-icon cs-icon-chevron-left"></i> </span> <span class="cs-entry__prev-next-text"> Previous Article </span></div><div class="cs-entry"><div class="cs-entry__outer"><div class="cs-entry__thumbnail cs-entry__inner cs-overlay-ratio cs-ratio-square"><div class="cs-overlay-background cs-overlay-transparent"> <img width="110" height="110" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAyMjAgMjIwIiB3aWR0aD0iMjIwIiBoZWlnaHQ9IjIyMCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGa2Fuc2FzLWxhd21ha2Vycy1jb25zaWRlci1zdHJpY3RseS1yZWd1bGF0ZWQtbWVkaWNhbC1tYXJpanVhbmEtcHJvZ3JhbS1mZWF0dXJlZC0yMjB4MjIwLmpwZyIgZGF0YS13PSIyMjAiIGRhdGEtaD0iMjIwIiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" class="attachment-csco-small size-csco-small wp-post-image" alt="Kansas Lawmakers Consider Strictly Regulated Medical Marijuana Program"  sizes="(max-width: 110px) 100vw, 110px" /></div></div><div class="cs-entry__inner cs-entry__content "><h2 class="cs-entry__title"> <span>Kansas Lawmakers Consider Strictly Regulated Medical Marijuana Program</span></h2><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://hightimes.com/author/ajherrington/" title="View all posts by A.J. Herrington"><span class="cs-photo"><img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA4MCA4MCIgd2lkdGg9IjgwIiBoZWlnaHQ9IjgwIiBkYXRhLXU9Imh0dHBzJTNBJTJGJTJGaGlnaHRpbWVzLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAxNyUyRjEwJTJGQUotSGVycmluZ3Rvbi1BdXRob3ItUHJvZmlsZS1QaWMtODB4ODAuanBnIiBkYXRhLXc9IjgwIiBkYXRhLWg9IjgwIiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" width="26" height="26" alt="A.J. Herrington" class="avatar avatar-26 wp-user-avatar wp-user-avatar-26 alignnone photo" /></span><span class="cs-by">by</span><span class="cs-author">A.J. Herrington</span></a></div></div></div></div></div></div></div></div></div></div></div><aside id="secondary" class="cs-sidebar__area cs-widget-area"><div class="cs-sidebar__inner"><div class="widget powerkit_social_links_widget-2 powerkit_social_links_widget"><div class="widget-body"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Follow Us</span></span></h5><div class="pk-social-links-wrap pk-social-links-template-columns pk-social-links-template-col-4 pk-social-links-align-default pk-social-links-scheme-bold pk-social-links-scheme-light-rounded pk-social-links-titles-enabled pk-social-links-counts-enabled pk-social-links-labels-disabled pk-social-links-mode-php pk-social-links-mode-rest"><div class="pk-social-links-items"><div class="pk-social-links-item pk-social-links-facebook " data-id="facebook"> <a href="https://facebook.com/hightimesmag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-facebook"></i> <span class="pk-social-links-title pk-font-heading">Facebook</span> <span class="pk-social-links-count pk-font-secondary">5.8M</span> </a></div><div class="pk-social-links-item pk-social-links-twitter " data-id="twitter"> <a href="https://twitter.com/high_times_mag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-twitter"></i> <span class="pk-social-links-title pk-font-heading">Twitter</span> <span class="pk-social-links-count pk-font-secondary">720K</span> </a></div><div class="pk-social-links-item pk-social-links-instagram " data-id="instagram"> <a href="https://www.instagram.com/hightimesmagazine" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-instagram"></i> <span class="pk-social-links-title pk-font-heading">Instagram</span> <span class="pk-social-links-count pk-font-secondary">2.5M</span> </a></div><div class="pk-social-links-item pk-social-links-youtube " data-id="youtube"> <a href="https://www.youtube.com/channel/UCFQ7vc-dWlSUZd6OqsAepMA" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-youtube"></i> <span class="pk-social-links-title pk-font-heading">YouTube</span> <span class="pk-social-links-count pk-font-secondary">270K</span> </a></div></div></div></div></div><div class="widget ai_widget-11 ai_widget ai-sticky-widget"><div class='code-block code-block-2' style='margin: 8px auto; text-align: center; display: block; clear: both;'>   <div id='div-gpt-ad-1582512780446-0' style='width: 300px; height: 600px;'>  </div></div></div></div></aside></div><div class="cs-entry__post-related"><h5 class="cs-section-heading cnvs-block-section-heading is-style-cnvs-block-section-heading-default halignleft "><span class="cnvs-section-title"><span>Related Posts</span></span></h5><div class="cs-entry__post-wrap"><article class="post-277959 post type-post status-publish format-standard has-post-thumbnail category-music category-culture tag-featured tag-interviews tag-musicians cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse"><div class="cs-overlay-background"> <img width="260" height="195" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA2MDAgNDUwIiB3aWR0aD0iNjAwIiBoZWlnaHQ9IjQ1MCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGanVzdGluLWJvcmV0YS1wbGF5cy1wYXJ0LW11c2ljLWN5Y2xlLWxpZmUtZmVhdHVyZWQtNjAweDQ1MC5qcGVnIiBkYXRhLXc9IjYwMCIgZGF0YS1oPSI0NTAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image" alt="Justin Boreta Plays His Part In The Music Cycle Of Life"  sizes="(max-width: 260px) 100vw, 260px" /></div><div class="cs-overlay-content"> <span class="cs-entry__read-more">Read More</span></div> <a href="https://hightimes.com/culture/music/justin-boreta-plays-part-music-cycle-life/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><div class="cs-entry__post-meta" ><div class="cs-meta-category"><ul class="post-categories"><li><a href="https://hightimes.com/culture/music/" rel="category tag">Music</a></li><li><a href="https://hightimes.com/culture/" rel="category tag">Culture</a></li></ul></div></div><h2 class="cs-entry__title"><a href="https://hightimes.com/culture/music/justin-boreta-plays-part-music-cycle-life/">Justin Boreta Plays His Part In The Music Cycle Of Life</a></h2><div class="cs-entry__excerpt"> The Glitch Mob member reflects on elevating with psychedelics, his new ambient project, Superposition, and why the best music isn’t made for Spotify algorithms.</div><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://hightimes.com/author/stephenladdin/" title="View all posts by Stephen Laddin"><span class="cs-by">by</span><span class="cs-author">Stephen Laddin</span></a></div><div class="cs-meta-date">March 23, 2021</div></div></div></div></article><article class="post-277834 post type-post status-publish format-standard has-post-thumbnail category-culture category-music tag-featured tag-grateful-dead tag-music cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse"><div class="cs-overlay-background"> <img width="260" height="195" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA2MDAgNDUwIiB3aWR0aD0iNjAwIiBoZWlnaHQ9IjQ1MCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGZXNzYXktbXktbXlzdGljYWwtam91cm5leS13ZWVkLW11c2ljLWZlYXR1cmVkLTYwMHg0NTAuanBnIiBkYXRhLXc9IjYwMCIgZGF0YS1oPSI0NTAiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image" alt="Essay: My Mystical Journey with Weed And Music"  sizes="(max-width: 260px) 100vw, 260px" /></div><div class="cs-overlay-content"> <span class="cs-entry__read-more">Read More</span></div> <a href="https://hightimes.com/culture/essay-my-mystical-journey-weed-music/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><div class="cs-entry__post-meta" ><div class="cs-meta-category"><ul class="post-categories"><li><a href="https://hightimes.com/culture/" rel="category tag">Culture</a></li><li><a href="https://hightimes.com/culture/music/" rel="category tag">Music</a></li></ul></div></div><h2 class="cs-entry__title"><a href="https://hightimes.com/culture/essay-my-mystical-journey-weed-music/">Essay: My Mystical Journey with Weed And Music</a></h2><div class="cs-entry__excerpt"> A personal essay on the intricacies of enjoying music while stoned.</div><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://hightimes.com/author/connordouglas/" title="View all posts by Connor Douglas"><span class="cs-by">by</span><span class="cs-author">Connor Douglas</span></a></div><div class="cs-meta-date">March 17, 2021</div></div></div></div></article><article class="post-277804 post type-post status-publish format-standard has-post-thumbnail category-culture tag-column tag-interviews tag-stash-boxes cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse"><div class="cs-overlay-background"> <img width="260" height="195" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxMDgwIDgxMSIgd2lkdGg9IjEwODAiIGhlaWdodD0iODExIiBkYXRhLXU9Imh0dHBzJTNBJTJGJTJGM25jYjg4NG91NWU0OXQ5ZWIzZnBldXIxLXdwZW5naW5lLm5ldGRuYS1zc2wuY29tJTJGd3AtY29udGVudCUyRnVwbG9hZHMlMkYyMDIxJTJGMDMlMkZ3aGF0cy15b3VyLXN0YXNoLXBhdHJpY2sta2lsY295bmUtaG9zdC1jcmVhdG9yLXplbi1jYW5uYWJvbnNhaS1mZWF0dXJlZC5qcGciIGRhdGEtdz0iMTA4MCIgZGF0YS1oPSI4MTEiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image" alt="What’s in Your Stash? Patrick Kilcoyne, Host and Creator of Zen Cannabonsai"  sizes="(max-width: 260px) 100vw, 260px" /></div><div class="cs-overlay-content"> <span class="cs-entry__read-more">Read More</span></div> <a href="https://hightimes.com/culture/whats-your-stash-patrick-kilcoyne-host-creator-zen-cannabonsai/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><div class="cs-entry__post-meta" ><div class="cs-meta-category"><ul class="post-categories"><li><a href="https://hightimes.com/culture/" rel="category tag">Culture</a></li></ul></div></div><h2 class="cs-entry__title"><a href="https://hightimes.com/culture/whats-your-stash-patrick-kilcoyne-host-creator-zen-cannabonsai/">What’s in Your Stash? Patrick Kilcoyne, Host and Creator of Zen Cannabonsai</a></h2><div class="cs-entry__excerpt"> Cannabis marketeer turned cannabis bonsai artist.</div><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://hightimes.com/author/sharonletts/" title="View all posts by Sharon Letts"><span class="cs-by">by</span><span class="cs-author">Sharon Letts</span></a></div><div class="cs-meta-date">March 16, 2021</div></div></div></div></article><article class="post-277734 post type-post status-publish format-standard has-post-thumbnail category-music category-culture tag-featured tag-hip-hop tag-musicians cs-entry cs-video-wrap"><div class="cs-entry__outer"><div class="cs-entry__inner cs-entry__thumbnail cs-entry__overlay cs-overlay-ratio cs-ratio-original" data-scheme="inverse"><div class="cs-overlay-background"> <img width="260" height="195" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCA2MDAgNDUwIiB3aWR0aD0iNjAwIiBoZWlnaHQ9IjQ1MCIgZGF0YS11PSJodHRwcyUzQSUyRiUyRjNuY2I4ODRvdTVlNDl0OWViM2ZwZXVyMS13cGVuZ2luZS5uZXRkbmEtc3NsLmNvbSUyRndwLWNvbnRlbnQlMkZ1cGxvYWRzJTJGMjAyMSUyRjAzJTJGcmVtZW1iZXJpbmctaGlwLWhvcC1sZWdlbmQtbmF0ZS1kb2dnLWFubml2ZXJzYXJ5LWhpcy1kZWF0aC1mZWF0dXJlZC02MDB4NDUwLmpwZyIgZGF0YS13PSI2MDAiIGRhdGEtaD0iNDUwIiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" class="attachment-csco-thumbnail-small size-csco-thumbnail-small wp-post-image" alt="Remembering Hip Hop Legend Nate Dogg On The 10th Anniversary of His Death"  sizes="(max-width: 260px) 100vw, 260px" /></div><div class="cs-overlay-content"> <span class="cs-entry__read-more">Read More</span></div> <a href="https://hightimes.com/culture/music/remembering-hip-hop-legend-nate-dogg-anniversary-his-death/" class="cs-overlay-link"></a></div><div class="cs-entry__inner cs-entry__content"><div class="cs-entry__post-meta" ><div class="cs-meta-category"><ul class="post-categories"><li><a href="https://hightimes.com/culture/music/" rel="category tag">Music</a></li><li><a href="https://hightimes.com/culture/" rel="category tag">Culture</a></li></ul></div></div><h2 class="cs-entry__title"><a href="https://hightimes.com/culture/music/remembering-hip-hop-legend-nate-dogg-anniversary-his-death/">Remembering Hip Hop Legend Nate Dogg On The 10th Anniversary of His Death</a></h2><div class="cs-entry__excerpt"> “Hey, hey, hey, hey. Smoke weed every day."—Nate Dogg (1969-2011)</div><div class="cs-entry__post-meta" ><div class="cs-meta-author"><a class="cs-meta-author-inner url fn n" href="https://hightimes.com/author/sethzaplin/" title="View all posts by Seth Zaplin"><span class="cs-by">by</span><span class="cs-author">Seth Zaplin</span></a></div><div class="cs-meta-date">March 15, 2021</div></div></div></div></article></div></div></div></div></main><footer class="cs-footer cs-footer-one" data-scheme="dark"><div class="cs-site-subscribe"><div class="cs-container"><div class="cs-site-subscribe__item"><div class="cs-site-subscribe__text"> <span class="cs-subscribe-text">Weekly Newsletter</span> <span class="cs-subscribe-arrow"> <img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxIDEiIHdpZHRoPSIxIiBoZWlnaHQ9IjEiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkZoaWdodGltZXMuY29tJTJGd3AtY29udGVudCUyRnRoZW1lcyUyRm5ld3NibG9jayUyRmFzc2V0cyUyRnN0YXRpYyUyRmltYWdlcyUyRnN1YnNjcmliZS1hcnJvdy5zdmciIGRhdGEtdz0iMSIgZGF0YS1oPSIxIiBkYXRhLWJpcD0iIj48L3N2Zz4=" data-spai="1" alt="subscribe"> </span></div><div class="cs-site-subscribe__form"><div class="cs-site-subscribe__info"><h4 class="cs-site-subscribe__title">Subscribe For Free</h4> <span class="cs-site-subscribe__info-text">Get notified of our the latest cannabis news, exclusive brand deals, events updates and more!</span></div><div class="pk-subscribe-form-wrap pk-subscribe-form-block"><div class="pk-subscribe-container "><div class="pk-subscribe-data"><form method="post" class="subscription"> <input type="hidden" name="list_id" value="3c14e9f298"><div class="pk-input-group"> <input type="text" name="EMAIL" class="email form-control" placeholder="Enter your email"> <button class="pk-subscribe-submit" type="submit">Subscribe</button></div> <input type="hidden" name="_wp_http_referer" value="/author/hightimes/" /></form></div></div></div></div></div></div></div><div class="cs-container"><div class="cs-footer__item"><div class="cs-footer__col cs-col-left"><div class="cs-footer__inner"><div class="cs-logo"> <a class="cs-footer__logo cs-logo-once" href="https://hightimes.com/"> <img src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAzMjAgODIiIHdpZHRoPSIzMjAiIGhlaWdodD0iODIiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkZoaWdodGltZXMuY29tJTJGd3AtY29udGVudCUyRnVwbG9hZHMlMkYyMDE2JTJGMDYlMkZIVC1sb2dvLnBuZyIgZGF0YS13PSIzMjAiIGRhdGEtaD0iODIiIGRhdGEtYmlwPSIiPjwvc3ZnPg==" data-spai="1" alt="High Times" > </a></div><div class="cs-footer__desc"> Since 1974, High Times Magazine has been the #1 resource for cannabis news, culture, brands and marijuana legalization laws.</div></div></div><div class="cs-footer__col cs-col-center"><div class="footer-nav-menu"><ul id="menu-ht-footer-nav-1" class="cs-footer__nav "><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-275350"><a href="/magazine-subscription">Subscribe</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271309"><a href="https://hightimes.com/advertise/">Advertise</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271311"><a href="https://hightimes.com/classifieds/">Classifieds</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-271310"><a href="https://hightimes.com/legal/">Legal Directory</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174072"><a href="https://hightimes.com/about/">Our Company</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275853"><a href="https://hightimes.com/terms-of-use/">Terms of Use</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-174074"><a href="https://hightimes.com/privacy-policy/">Privacy Policy</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-275854"><a href="https://hightimes.com/california-residents-privacy-notice/">California Residents Privacy Notice</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174076"><a href="https://hightimes.com/submissions/">Write For Us</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-196428"><a href="https://ir.hightimes.com">Investor Relations</a></li></ul></div></div><div class="cs-footer__col cs-col-right"><div class="cs-footer-social-links"><div class="pk-social-links-wrap pk-social-links-template-nav pk-social-links-align-default pk-social-links-scheme-default pk-social-links-titles-disabled pk-social-links-counts-disabled pk-social-links-labels-disabled"><div class="pk-social-links-items"><div class="pk-social-links-item pk-social-links-facebook pk-social-links-no-count" data-id="facebook"> <a href="https://facebook.com/hightimesmag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-facebook"></i> </a></div><div class="pk-social-links-item pk-social-links-twitter pk-social-links-no-count" data-id="twitter"> <a href="https://twitter.com/high_times_mag" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-twitter"></i> </a></div><div class="pk-social-links-item pk-social-links-instagram pk-social-links-no-count" data-id="instagram"> <a href="https://www.instagram.com/hightimesmagazine" class="pk-social-links-link" target="_blank" rel="nofollow"> <i class="pk-social-links-icon pk-icon pk-icon-instagram"></i> </a></div></div></div></div></div></div></div></footer></div></div>  <a href="#top" class="pk-scroll-to-top"> <i class="pk-icon pk-icon-up"></i> </a><div class="pk-mobile-share-overlay"><div class="pk-share-buttons-wrap pk-share-buttons-layout-horizontal pk-share-buttons-scheme-default pk-share-buttons-has-total-counts pk-share-buttons-mobile-share pk-share-buttons-mode-none" data-post-id="277973" data-share-url="https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" ><div class="pk-share-buttons-total pk-share-buttons-total-no-count"><div class="pk-share-buttons-title pk-font-primary">Total</div><div class="pk-share-buttons-count pk-font-heading">0</div><div class="pk-share-buttons-label pk-font-secondary">Share</div></div><div class="pk-share-buttons-items"><div class="pk-share-buttons-item pk-share-buttons-facebook pk-share-buttons-no-count" data-id="facebook"> <a href="https://www.facebook.com/sharer.php?u=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-facebook"></i> </a></div><div class="pk-share-buttons-item pk-share-buttons-twitter pk-share-buttons-no-count" data-id="twitter"> <a href="https://twitter.com/share?&text=Here%E2%80%99s%20to%20%3Ci%3E%20Boogie%20%3C%2Fi%3E%20Being%20the%20Start%20of%20a%20Prolific%20Filmmaking%20Career%20for%20Eddie%20Huang&via=high_times_mag&url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-twitter"></i> </a></div><div class="pk-share-buttons-item pk-share-buttons-linkedin pk-share-buttons-no-count" data-id="linkedin"> <a href="https://www.linkedin.com/shareArticle?mini=true&url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-linkedin"></i> </a></div><div class="pk-share-buttons-item pk-share-buttons-reddit pk-share-buttons-no-count" data-id="reddit"> <a href="http://www.reddit.com/submit?url=https://hightimes.com/culture/movies/heres-boogie-being-start-prolific-filmmaking-career-eddie-huang/" class="pk-share-buttons-link" target="_blank"> <i class="pk-share-buttons-icon pk-icon pk-icon-reddit"></i> </a></div></div></div></div>  <script type='text/javascript' id='rocket-browser-checker-js-after'>"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}()</script> <script type='text/javascript' id='rocket-delay-js-js-after'>(function(){"use strict";var e=function(){function n(e,t){for(var r=0;r<t.length;r++){var n=t[r];n.enumerable=n.enumerable||!1,n.configurable=!0,"value"in n&&(n.writable=!0),Object.defineProperty(e,n.key,n)}}return function(e,t,r){return t&&n(e.prototype,t),r&&n(e,r),e}}();function n(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function r(e,t){n(this,r),this.attrName="data-rocketlazyloadscript",this.browser=t,this.options=this.browser.options,this.triggerEvents=e,this.userEventListener=this.triggerListener.bind(this)}return e(r,[{key:"init",value:function(){this._addEventListener(this)}},{key:"reset",value:function(){this._removeEventListener(this)}},{key:"_addEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.addEventListener(e,t.userEventListener,t.options)})}},{key:"_removeEventListener",value:function(t){this.triggerEvents.forEach(function(e){return window.removeEventListener(e,t.userEventListener,t.options)})}},{key:"_loadScriptSrc",value:function(){var r=this,e=document.querySelectorAll("script["+this.attrName+"]");0!==e.length&&Array.prototype.slice.call(e).forEach(function(e){var t=e.getAttribute(r.attrName);e.setAttribute("src",t),e.removeAttribute(r.attrName)}),this.reset()}},{key:"triggerListener",value:function(){this._loadScriptSrc(),this._removeEventListener(this)}}],[{key:"run",value:function(){RocketBrowserCompatibilityChecker&&new r(["keydown","mouseover","touchmove","touchstart","wheel"],new RocketBrowserCompatibilityChecker({passive:!0})).init()}}]),r}();t.run()}())</script> <script type='text/javascript' id='rocket-preload-links-js-extra'>/* <![CDATA[*/var RocketPreloadLinksConfig={"excludeUris":"\/(.+\/)?feed\/?.+\/?|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|php|pdf|html|htm","siteUrl":"https:\/\/hightimes.com","onHoverDelay":"100","rateThrottle":"3"}/*]]> */</script> <script type='text/javascript' id='rocket-preload-links-js-after'>(function(){"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run()}())</script> <script  async src='//static.klaviyo.com/onsite/js/klaviyo.js?company_id=XEJZ8w'></script><script  type='text/javascript' id='wpo_min-footer-1-js-extra'>/* <![CDATA[ */ var canvasJG={"rtl":""};var canvas_sg_flickity={"page_info_sep":" of "};var wpcf7={"cached":"1"};var powerkit_lightbox_localize={"text_previous":"Previous","text_next":"Next","text_close":"Close","text_loading":"Loading","text_counter":"of","single_image_selectors":".entry-content img","gallery_selectors":".wp-block-gallery,.gallery","exclude_selectors":"","zoom_icon":"1"};var opt_in={"ajax_url":"https:\/\/hightimes.com\/wp-admin\/admin-ajax.php","warning_privacy":"Please confirm that you agree with our policies."};var powerkit_sg_flickity={"page_info_sep":" of "};var spai_settings={"api_url":"https:\/\/cdn.shortpixel.ai\/spai\/w_%WIDTH%+q_lossy+ret_img","api_short_url":"https:\/\/cdn.shortpixel.ai\/spai\/ret_img","method":"src","crop":"","lqip":"","lazy_threshold":"500","hover_handling":"","native_lazy":"","serve_svg":"1","debug":"","site_url":"https:\/\/hightimes.com","plugin_url":"https:\/\/hightimes.com\/wp-content\/plugins\/shortpixel-adaptive-images","version":"2.1.6","excluded_selectors":[],"eager_selectors":[],"noresize_selectors":[],"alter2wh":"","use_first_sizes":[],"active_integrations":{"nextgen":!1,"modula":!1,"elementor":!1,"elementor-addons":!1,"viba-portfolio":!1,"envira":!1,"everest":!1,"wp-bakery":!1,"woocommerce":!1,"foo":!1,"oxygen":!1,"slider-revolution":!1,"custom-facebook-feed":!1,"smart-slider":!1,"wp-grid-builder":!1,"the-grid":!1,"social-pug":!1,"content-views":!1,"acf":!1,"wp-rocket":{"lazyload":!1,"css-filter":!0,"minify-css":!0,"defer-all-js":!1},"swift-performance":!1,"imagify":{"active":!1},"wp-fastest-cache":!1,"litespeed-cache":!1,"w3-total-cache":!1,"wp-optimize":!1,"theme":"High Times Theme"},"parse_css_files":"1","backgrounds_max_width":"1920","sep":"+","webp":"1","extensions_to_webp":{"png":!0,"jpg":!0,"gif":!0},"sniper":"https:\/\/hightimes.com\/wp-content\/plugins\/shortpixel-adaptive-images\/assets\/img\/target.cur","affected_tags":"{\"link\":1,\"script\":2}","ajax_url":"https:\/\/hightimes.com\/wp-admin\/admin-ajax.php","excluded_paths":["cmVnZXg6L1wvXC8oW15cL10qXC58KWdyYXZhdGFyLmNvbVwvLw=="]};var csLocalize={"darkMode":"false"};var csco_mega_menu={"rest_url":"https:\/\/hightimes.com\/wp-json\/csco\/v1\/menu-posts"};var searchwp_live_search_params=[];searchwp_live_search_params={"ajaxurl":"https:\/\/hightimes.com\/wp-admin\/admin-ajax.php","origin_id":277973,"config":{"default":{"engine":"default","input":{"delay":300,"min_chars":3},"results":{"position":"bottom","width":"auto","offset":{"x":0,"y":5}},"spinner":{"lines":12,"length":8,"width":3,"radius":8,"scale":1,"corners":1,"color":"#424242","fadeColor":"transparent","speed":1,"rotate":0,"animation":"searchwp-spinner-line-fade-quick","direction":1,"zIndex":2000000000,"className":"spinner","top":"50%","left":"50%","shadow":"0 0 1px transparent","position":"absolute"}}},"msg_no_config_found":"No valid SearchWP Live Search configuration found!","aria_instructions":"When autocomplete results are available use up and down arrows to review and enter to go to the desired page. Touch device users, explore by touch or with swipe gestures."};var klUser={"current_user_email":"","commenter_email":""} /* ]]> */</script>  <script   type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LeWKN8UAAAAAEsmMNPGvsL_SVrKYb3SOB7arlgy&#038;ver=3.0' id='google-recaptcha-js'></script>   <script type="text/javascript">window.addEventListener('DOMContentLoaded',function(){"use strict";(function($){$(window).on('load',function(){$('.pk-share-buttons-mode-rest').each(function(){var powerkitButtonsIds=[],powerkitButtonsBox=$(this);if(!powerkitButtonsBox.hasClass('pk-share-buttons-has-counts')&&!powerkitButtonsBox.hasClass('pk-share-buttons-has-total-counts')){return}
powerkitButtonsBox.find('.pk-share-buttons-item').each(function(){if($(this).attr('data-id').length>0){powerkitButtonsIds.push($(this).attr('data-id'))}});var powerkitButtonsData={};if(powerkitButtonsIds.length>0){powerkitButtonsData={'ids':powerkitButtonsIds.join(),'post_id':powerkitButtonsBox.attr('data-post-id'),'url':powerkitButtonsBox.attr('data-share-url'),}}
$.ajax({type:'GET',url:'https://hightimes.com/wp-json/social-share/v1/get-shares',data:powerkitButtonsData,beforeSend:function(){powerkitButtonsBox.addClass('pk-share-buttons-loading')},success:function(response){if(!$.isEmptyObject(response)&&!response.hasOwnProperty('code')){$.each(response,function(index,data){if(index!=='total_count'){var powerkitButtonsItem=powerkitButtonsBox.find('.pk-share-buttons-item[data-id="'+index+'"]');if(data.hasOwnProperty('count')&&data.count){powerkitButtonsItem.removeClass('pk-share-buttons-no-count').addClass('pk-share-buttons-item-count');powerkitButtonsItem.find('.pk-share-buttons-count').html(data.count)}else{powerkitButtonsItem.addClass('pk-share-buttons-no-count')}}});if(powerkitButtonsBox.hasClass('pk-share-buttons-has-total-counts')&&response.hasOwnProperty('total_count')){var powerkitButtonsTotalBox=powerkitButtonsBox.find('.pk-share-buttons-total');if(response.total_count){powerkitButtonsTotalBox.find('.pk-share-buttons-count').html(response.total_count);powerkitButtonsTotalBox.show().removeClass('pk-share-buttons-total-no-count')}}}
powerkitButtonsBox.removeClass('pk-share-buttons-loading')},error:function(){powerkitButtonsBox.removeClass('pk-share-buttons-loading')}})})})})(jQuery)});</script>   <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-W3KQM5M" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id='div-gpt-ad-1524692041862-0' style='height:1px; width:1px;'>  </div><div id="banner-advert-container" class="adsense sponsor-ad" style="position:absolute; z-index: -10; height: 1px; width: 1px; top: -1px; left: -1px;"><img id="im_popupFixed" class="ad-inserter adsense ad-img ad-index" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHZpZXdCb3g9IjAgMCAxIDEiIHdpZHRoPSIxIiBoZWlnaHQ9IjEiIGRhdGEtdT0iaHR0cHMlM0ElMkYlMkZoaWdodGltZXMuY29tJTJGd3AtY29udGVudCUyRnBsdWdpbnMlMkZhZC1pbnNlcnRlci1wcm8lMkZpbWFnZXMlMkZhZHMucG5nIiBkYXRhLXc9IjEiIGRhdGEtaD0iMSIgZGF0YS1iaXA9IiI+PC9zdmc+" data-spai="1"></div> <img id="ai-adb-adnxs" src="" style="position:absolute; z-index: -10; width: 1px; height: 1px; top: -1px; left: -1px;"> <script data-rocketlazyloadscript='https://www.google-analytics.com/analytics.js' async id="ai-adb-ga" ></script> <script async id="ai-adb-mn" src="//contextual.media.net/dmedianet.js"></script>       <script>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</script> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://3ncb884ou5e49t9eb3fpeur1-wpengine.netdna-ssl.com/wp-content/plugins/wp-rocket/assets/js/lazyload/16.1/lazyload.min.js"></script> <script>"use strict";var wprRemoveCPCSS=function wprRemoveCPCSS(){var elem;document.querySelector('link[data-rocket-async="style"][rel="preload"]')?setTimeout(wprRemoveCPCSS,200):(elem=document.getElementById("rocket-critical-css"))&&"remove"in elem&&elem.remove()};window.addEventListener?window.addEventListener("load",wprRemoveCPCSS):window.attachEvent&&window.attachEvent("onload",wprRemoveCPCSS);</script><script src="https://hightimes.com/wp-content/cache/min/1/787ff7cd43ef326bf1ceca25f32156e0.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://hightimes.com/wp-content/cache/min/1/6268a7e3b9e0805bfdc5d6c438ff95c7.css" media="all" data-minify="1" /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->